Truck Still Not Performing Major Issues Please Help

silviarunner

New Member
My 2002 Frontier Supercharged is still having Major power loss issues across the board on all RPMS. There seems to be no difference in power if I floor it or put it down 1/4 throttle. VERY difficult to get to 60 MPH. If your going up hill you wont be able to go faster then 45 even flooring it. The only Code I am showing is P0057 and this cant cause this many issues. The truck has 172K on it and here is what has been replaced trying to fix this issue.

Timing Belt
Timing Belt Tensioner
All Serpentine Belts
Fuel Tank
Fuel Filter
Distributer Rotor
Distributer Cap
New Plug Wires OEM
New Spark Plugs OEM
4x4 Headers with CEL Fix
Cats Removed - Thought it was a clogged cat
Full Exhaust put in
Knock Sensor replaced OEM
Fuel Regulator OEM

I am at a loss of words and we are nearing the 3.5K range in cost so far just to try to fix this issue and nothing is working.

I am looking out for anyone that can help. I would be willing to give out my number if you want to talk on the phone about it. If there is anyone out there please help me.
 

mdawg4x4

Administrator
Who did the timing belt replacement?
Is there a possibility of timing being slightly off?

By knock sensor, I assume you mean the O2 sensor?
Is there more than 1? I don't remember.
 

silviarunner

New Member
mdawg4x4 said:
Who did the timing belt replacement?
Is there a possibility of timing being slightly off?

By knock sensor, I assume you mean the O2 sensor?
Is there more than 1? I don't remember.
I did the timing replacement. Lets say the timing was off would that cause this dramatic power loss?
 

mdawg4x4

Administrator
It could. Those with programmers on the 2nd gen advance the timing 2 degrees to gain power. Not huge gains, but a few HP.
 
Top